Действие MultipartFormGenerateFromMessage генерирует HTTP сообщения в формате multipart-formdata из сообщения.
Параметры:
Название |
Обязательность |
Допустимые значения |
Описание |
message_field_name |
- |
Текстовое значение. |
Имя поля сообщения, добавляемого в multipart-formdata. |
message_file_name |
- |
Текстовое значение. |
Имя файла в multipart-formdata для сообщения, если сообщение указано в двоичной форме. Если не указано, то используется параметр file_name исходного сообщения. |
message_content_type |
- |
Текстовое значение. |
Тип содержимого для поля с сообщением, если не указано, используется тип содержимого из исходного сообщения или text/plain для недвоичного сообщения, или application/octet-stream для двоичного сообщения. |
multipart_mode |
- |
Текстовое значение. - STRICT - соответствие требованиям RFC 822, RFC 2045, RFC 2046; - BROWSER_COMPATIBLE - режим, совместимый с браузером, т.е. записывается только расположение содержимого. Используется кодировка содержимого; - RFC6532 - совместимый с RFC6532. |
По умолчанию: STRICT. |
result_boundary |
- |
Текстовое значение. |
Указывает границу для результирующего сообщения, если она не указана - автоматически генерирует ее. |
result_mime_sub_type |
- |
Текстовое значение. |
Указывает подтип результирующего MIME-кода. |
result_charset |
- |
Текстовое значение. |
Указывает результирующую кодировку символов. По умолчанию: utf8. |
result_content_type |
- |
Строковое значение. |
Указывает тип содержимого результата. |
rules |
- |
Последовательность значений. |
Указывает правила включения дополнительных полей в multipart-formdata. - operation_type Текстовое значение: - var - получает сообщение из переменной; - peek - выбирает, но не удаляет из заголовка очереди хранилища сообщений; - peek_last - операция peek выполняется из хвоста очереди, - poll - выбирает и удаляет из заголовка очереди хранилища сообщений; - poll_last - операция poll выполняется из хвоста очереди; - peek_last_by_filter - операция peek_last с использованием дополнительных фильтров и ограничений; - peek_by_filter - операция peek с использованием дополнительных фильтров и ограничений; - poll_by_filter - операция poll с использованием дополнительных фильтров и ограничений; - poll_last_by_filter - операция poll_last с использованием дополнительных фильтров и ограничений; - peek_all - операция peek выполняется с выбором всех сообщений; - poll_all - операция poll выполняется с выбором всех сообщений; - peek_last_all - операция peek_last выполняется с выбором всех сообщений; - poll_last_all - операция poll_last выполняется с выбором всех сообщений; - peek_with_limit - операция peek выполняется с выбором определенного количества сообщений; - peek_last_with_limit - операция peek_last выполняется с выбором определенного количества сообщений; - poll_last_with_limit - операция poll_last выполняется с выбором определенного количества сообщений; - poll_with_limit - операция poll выполняется с выбором определенного количества сообщений. -field_name Текстовое значение. Задает имя поля. Обязательный параметр. -mime_type Строковое значение. Задает mime-тип для поля сообщения. -var_name Строковое значение. Задает название переменной при использовании operation_type: var. -limit Целочисленное значение. Задает предельное количество сообщений для выбора. Используется в случае: operation_type: peek_by_filter или operation_type: poll_by_filter или operation_type: poll_with_limit или operation_type: peek_with_limit или operation_type: peek_last_by_filter или operation_type: poll_last_by_filter или operation_type: peek_last_with_limit или operation_type: poll_last_with_limit. - message_filters Используется в случае: *operation_type: operation_type: accumulator_peek_by_filter или operation_type: poll_by_filter или operation_type: peek_last_by_filter или operation_type: poll_last_by_filter. - filter_type. Текстовое значение. - id - фильтрация по id сообщения; - property - фильтрация по одному из свойств сообщения; - action_name - фильтрация по названию действию ; - action_id - фильтрация по id действия. - key - название объекта. Используется в случае: filter_type: property. - value - значение для сравнения. Текстовое значение. - operator - один из сравнивающих операторов. Текстовое значение. |